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In Depth: Calc

Calc is the spreadsheet component of OpenOffice.org. Like most modern spreadsheet 

programs, it contains hundreds of features, many of which few average users will ever use. 

However, it doesn’t abandon its user-friendliness in the process and remains very simple 

for those who want to work on modest calculations, such as home finances or mortgage 

interest payments. In many regards, Calc is practically a clone of Excel, and anyone who 

has used Microsoft’s spreadsheet program will be able to get started with it immediately.

In this chapter, you’ll learn about some of the best features of Calc, as well as the basics 

of spreadsheet creation. To start Calc, click Applications ➤ Office ➤ OpenOffice.org 

Spreadsheet.

Entering and Formatting Data
As with all spreadsheets, entering data into a Calc document is simply a matter of selecting a 

cell and starting to type. You can enter practically anything into a cell, but a handful of 

symbols are not allowed. For example, you cannot enter an equals sign (=) in a cell, because 

Calc will assume that this is part of a formula.

■Tip  To enter any character into a cell, including an equals sign followed by a digit, precede it with an apostrophe 

(’). The apostrophe itself won’t be visible within the spreadsheet, and whatever you type won’t be interpreted 

in any special way; it will be seen as plain text.

Entering a sequence of data across a range of cells can be automated. Start typing the 

sequence of numbers (or words), highlight them, and then click and drag the small handle 

to the bottom right of the last cell. This will continue the sequence. You’ll see a tooltip window, 

indicating what the content of each cell will be. Figure 24-1 illustrates this process.
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Cells can be formatted in a variety of ways. For trivial formatting changes, such as selecting 

a different font or changing the number format, you can use the Formatting toolbar. For 

example, to turn the cell into one that displays currency, click the Number Format: Currency 

icon (remember that hovering the mouse cursor over each icon will reveal a tooltip). You 

can also increase or decrease the number of visible decimal places by clicking the relevant 

Formatting toolbar icon.

For more formatting options, right-click the individual cell, and select Format Cells 

from the menu. This displays the Format Cell dialog box, where you can change the style 

of the typeface, rotate text, place text at various angles, and so on. The Border tab of the 

Format Cell dialog box includes options for cell gridlines of varying thicknesses, which 

will appear when the document is eventually printed out.

Figure 24-1. You can automate the entering of data sequences by clicking and dragging.

Deleting and Inserting Data and Cells
Deleting data is also easy. Just highlight the cell or cells with the data you want to delete, 

and then press the Delete key. If you want to totally eradicate the cell along with its contents, 

right-click it and select Delete Cells. This will cause the data to the sides of the cell to move 

in. You’ll be given a choice on where you want the cells to shift from to fill the space: left, right, 

above, or below.

To insert a new cell, right-click where you would like to it to appear and select Insert 

Cells. Again, you’ll be prompted about where you want to shift the surrounding cells in 

order to make space for the new cell.
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Working with Formulas
Calc includes a large number of formulas. In addition to simple and complex math func-

tions, Calc offers a range of logical functions, as well as statistical and database tools. Certain 

formulas can also be used to manipulate text strings, such as dates.

You can get an idea of the available functions by clicking the Function Wizard button 

on the Formula bar (which is just below the Formatting toolbar). This will bring up a cate-

gorized list of formulas, along with brief outlines of what function the formula performs. 

If you would like more details, use the help system, which contains comprehensive 

descriptions of most of the formulas, complete with examples of the correct syntax.

■Note  The Function Wizard is actually a continuation of the wizard system you’ve seen in other 

OpenOffice.org programs, and some of the functions are also available elsewhere in the suite.

You can reuse formulas simply by cutting and pasting them. Calc is intelligent enough 

to work out which cells the transplanted formula should refer to, but it’s always a good 

idea to check to make sure the correct cells are referenced.

Using the Function Wizard

To use the Function Wizard to add a function, click the relevant button on the Formula 

bar, select the desired type of formula from the Category drop-down list, and then double-

click an entry in the Function list to select it. Following this, you’ll be prompted to input 

the relevant figures or define the appropriate data sources. Next to each text-entry box is 

a “shrink” button, which temporarily hides the wizard window, so you can select cells to be 

used within the formula.

Let’s look at a quick example of using the wizard to work out an average value of a 

number of cells.

1. Select the cell in which you want the result of the formula to appear.

2. Start the Function Wizard by clicking the button on the Formula bar. In the left-hand 

list of functions, double-click AVERAGE. The wizard will then present a list of fields 

on the right side of the dialog box, where you can enter the values to be averaged. 

You could type numeric values directly into these fields, but it’s more likely that 

you’ll want to reference individual cells from the spreadsheet.

3. Click and drag the top of the dialog box to move it so that the spreadsheet under-

neath is at least partially visible.
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4. Click the cursor in the “number 1” field of the dialog box, and then click the first 

cell you want to include in the calculation. This will automatically enter that cell ref-

erence into the field. By clicking the button to the right of the field, you can roll up the 

dialog box to allow better access to the spreadsheet. This will then display only 

the dialog box field you’re entering data into. To unroll the dialog box, click the button 

again. 

5. Click the next field in the dialog box, and then click the next cell you wish to include.

6. Repeat step 5 until all the fields you wish to include have been added to the fields in 

the dialog box (up to 30 can be selected; use the scroll bar on the right side of the 

wizard dialog box to reveal more fields).

7. Once you’ve finished, click the OK button. Calc will insert the formula into the cell 

you selected at the start, showing the result of the formula.

After you’ve added a formula with the wizard, you can edit it manually by clicking it 

and overtyping its contents in the Formula bar editing area. Alternatively, you can use the 

Function Wizard once again, by clicking the button on the Formula bar.

Summing Figures

To add the values of a number of cells, you could use the Function Wizard and select the 

SUM function, as shown in Figure 24-2. The procedure for choosing the cells is the same as 

described in the previous section.

However, Calc provides a far easier method of creating the sum formula. After posi-

tioning the cursor in an empty cell, simply click the Sum icon (the Greek sigma character) 

on the Formula bar, and then select the cells you wish to include in the sum. Then press 

Enter to see the results. If you place the cursor in a cell directly beneath a column of numbers, 

Calc may be clever enough to guess what you want to add and automatically select them. 

If it’s incorrect, simply highlight the correct range of cells.

■Tip  You can select more than one cell by holding down the Ctrl key. You can select a range of cells in 

succession by clicking and dragging the mouse.
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Figure 24-2. Creating formulas is easy using the Function Wizard.

Sorting Data
Within a spreadsheet, you may want to sort data according to any number of criteria. For 

example, you might want to show a list of numbers from highest to lowest, or rearrange 

a list of names so that they’re in alphabetical order. This is easy to do within Calc.

Start by highlighting the range of data you wish to sort. Alternatively, you can simply 

select one cell within it, because Calc is usually able to figure out the range of cells you 

want to use. Then select Data ➤ Sort from the main menu. Calc will automatically select a 

sort key, which will appear in the Sort By drop-down list, as shown in Figure 24-3. However, 

you can also choose your own sort key from the drop-down menu if you wish, and you can 

choose to further refine your selection by choosing up to two more sort subkeys from the 

other drop-down menus.
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Figure 24-3. Data can be sorted so that it’s in alphabetical or numerical order.

Creating Charts
Charts are useful, because they present a quick visual summary of data. Calc produces 

charts through a step-by-step wizard, so it becomes very easy indeed. Here are the steps:

1. Highlight the data you want to graph. Be careful to include only the data itself and 

not any surrounding cells, or even the cell that contains the title for the array of data.

2. Select the Insert ➤ Chart menu option, or click the Insert Chart button on the 

Standard toolbar.

3. The cursor turns into a target with a small graph next to it. Click and drag on the 

spreadsheet itself to define the area of the graph. This can be any size. Also, you can 

resize it later.

4. The wizard starts. The first step is to define the range of cells to be used for the 

chart. By highlighting the cells before you started, you’ve already done this, so you 

can click the Next button. However, first make sure that the First Row As Label 

option is selected.
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5. Choose the type of chart you wish to use. For most simple data selections, a bar 

graph is usually best. However, you might also choose to select a horizontal bar graph. 

Then click Next.

6. The wizard presents a subselection of graph types. You can also select whether 

gridlines are used to separate the various areas of the graph. Make your selections 

and click Next.

7. The last step allows you to give the chart a title and also choose whether you want 

a legend (a key that explains what the axes refer to) to appear next to it.

8. Click Create, and the chart will be created. Figure 24-4 shows an example.

Figure 24-4. Creating a chart is easy within Calc and adds a professional flourish to your 

spreadsheet.

Once you’ve created a chart, you can alter its size by clicking and dragging the handles. 

You can also change various graphical aspects by double-clicking them. However, keep in 

mind that the graph is actually a picture, so the properties you edit are limited to changing 

the color and size of various elements.

The chart is linked to your data. Whenever your data changes, so will your chart. This is 

done automatically and doesn’t require any user input.
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Using Filters
The Filter function in Calc lets you selectively hide rows of data. The spreadsheet user 

then selects which of the rows of data to view from a drop-down list that appears in the 

cell at the top of the rows, as shown in the example in Figure 24-5.

Figure 24-5. Filters allow you to selectively hide or show rows of data in a spreadsheet.

■Note  A Calc filter is a little like an Excel pivot chart, especially when it’s combined with an automatically 

generated chart.

Using filters in this way can be useful when you’re dealing with a very large table of 

data. It helps isolate figures so you can compare them side by side in an easy-to-follow 

format. For example, you could filter a table of sales figures by year.

To use the Filter function, start by highlighting the data you wish to see in the drop-

down list. Make sure the column header for the data is included, too. If you’re using the 

Filter feature on a table of data, this selection can be any column within the table, although 

it obviously makes sense to use a column that is pertinent to the filtering that will take 

place. After you’ve selected the data to filter, select Data ➤ Filter ➤ Autofilter. You should 

find that, in place of the column header, a drop-down list appears. When a user selects a 

various entry in the list, Calc will display only the corresponding row of the spreadsheet 

beneath.

To remove a filter, select Data ➤ Filter ➤ Remove Filter.
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Summary
In this chapter, we examined OpenOffice.org Calc. We looked at the basics of how data 

can be entered into a cell and how it can be formatted. Then you learned how to create 

formulas. This is easy to do with the Function Wizard function, which automates the task.

Next, you saw how to sort data in a spreadsheet. We also went through the steps for 

creating charts using a Calc wizard. Finally, we looked at creating data filters, which work 

rather like pivot charts in Microsoft Excel.

In the next chapter, we move on to Impress, the presentations component of 

OpenOffice.org.


